V8: Embedded JavaScript Engine for R

An R interface to Google's open source JavaScript engine. This package can now be compiled either with V8 version 6 or 7 (LTS) from nodejs or with the legacy 3.14/3.15 branch of V8.

Version: 2.2
Imports: Rcpp (≥ 0.12.12), jsonlite (≥ 1.0), curl (≥ 1.0), utils
LinkingTo: Rcpp
Suggests: testthat, knitr, rmarkdown
Published: 2019-04-13
Author: Jeroen Ooms ORCID iD [aut, cre]
Maintainer: Jeroen Ooms <jeroen at berkeley.edu>
BugReports: https://github.com/jeroen/v8/issues
License: MIT + file LICENSE
URL: https://github.com/jeroen/v8 (devel) https://v8.dev (upstream)
NeedsCompilation: yes
SystemRequirements: V8 version 6 or 7 is recommended, but 3.14 (legacy) is still supported as well. On Debian / Ubuntu you need either libv8-dev or libnode-dev, on Fedora use v8-devel.
Language: en-US
Materials: NEWS
In views: WebTechnologies
CRAN checks: V8 results

Downloads:

Reference manual: V8.pdf
Vignettes: Using NPM packages in V8
Introduction to V8 for R
Package source: V8_2.2.tar.gz
Windows binaries: r-devel: V8_2.2.zip, r-release: V8_2.2.zip, r-oldrel: V8_2.2.zip
OS X binaries: r-release: V8_2.2.tgz, r-oldrel: V8_2.1.tgz
Old sources: V8 archive

Reverse dependencies:

Reverse imports: AdhereR, ajv, colormap, concaveman, daff, dagitty, datapackage.r, DiagrammeRsvg, DOT, geojsonio, geojsonlint, gfer, ical, IMWatson, js, jsonld, jsonvalidate, lawn, lutz, minimist, plethem, randomcoloR, rchess, rchie, rjade, rmapshaper, subscreen, trackeRapp, uaparserjs, wellknown
Reverse suggests: dqshiny, RDML, reactR, shinyjs
Reverse enhances: d3r

Linking:

Please use the canonical form https://CRAN.R-project.org/package=V8 to link to this page.